描述

There is an integer array A1, A2 …AN. Each round you may choose two adjacent integers. If their sum is an odd number, the two adjacent integers can be deleted.

Can you work out the minimum length of the final array after elaborate deletions?

输入

The first line contains one integer N, indicating the length of the initial array.

The second line contains N integers, indicating A1, A2 …AN.

For 30% of the data:1 ≤ N ≤ 10

For 60% of the data:1 ≤ N ≤ 1000

For 100% of the data:1 ≤ N ≤ 1000000, 0 ≤ Ai ≤ 1000000000

输出

One line with an integer indicating the minimum length of the final array.

样例提示

(1,2) (3,4) (4,5) are deleted.

样例输入

7
1 1 2 3 4 4 5

样例输出

1

CODE

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
/*
*开始的思路(遍历一遍做异或判断)有个致命错误,如1 3 2 2,答案应该是0
*只需要统计偶数和奇数之差即可
*/
#include <iostream>
#include <cmath>
using namespace std;

int main()
{
int n, arr, cnt = 0;
cin >> n;
for(int i = 0; i < n; i++) {
cin >> arr;
if(arr & 1) cnt++;
}
cout << abs(n - cnt - cnt) << endl;
return 0;
}